OIT Tech 32px
Catmail to start blocking executable email attachments on July 16, 2015
Eduroam WiFi access now available on all OHIO campuses
New printing method coming June 29 for Libraries, College of Business and other locations
University to add 'eduroam' WiFi access in July, 2015
Clutter cleanup comes to Catmail on June 30
How to fix "Unrecognized course" Blackboard error in Campus Pack tools
Securing the cyber generation gap
Site licensing for Adobe, Microsoft and Smartsheet
May 2015 Blackboard upgrade completed
Top 30 targets for hackers: Are you on the list?
deco-circuit-banner

OIT recommends users pass on this week's Firefox 9 update for now

Tuesday, January 24, 2012
Sean O'Malley  

OIT is receiving reports that the most recent update to Firefox 9 may not work well with OHIO services like Blackboard, Bobcat Buy, PeopleSoft, and the My OHIO Student Center.  

If your computer asks you to upgrade to the latest version of Firefox in the coming weeks, please choose “Later.”

If you already upgraded to Firefox 9 and are having problems accessing OHIO online services, you can try using a different browser, or you can downgrade to a previous version of Firefox. On the other hand, if you are not experiencing any problems, then there is no need to change browsers or downgrade.

If you have any questions, please contact the OIT Service Desk at 740-593-1222.


Related Links

Downgrade to Firefox 3.6