OIT Tech 32px

Supported Browsers

In order to use the complete set of features, and get the best possible experience from CatMail, you need to use one of the recommended web browsers:

Windows XP / Vista/ 7 / 8:

  • Internet Explorer 7 or higher
  • Mozilla Firefox 3.0.1 or higher
  • Google Chrome

Mac OS X:

  • Mozilla Firefox 3.0.1 or higher
  • Safari 3.1 or higher
  • Google Chrome

Other web browsers will work for accessing CatMail, but you'll see a "light" version of the interface, with a different appearance and not all features available.

If your web browser isn't listed above, consider downloading and using one of the following:

For more information on exactly what features are available in which browser, see also Microsoft's list of Supported Browsers and Operating Systems.